Club robotique de Sophia-Antipolis

Accueil > Projets et études > Nos robots > Robots du club > Robots à roues > Hitec Mavin (2008) > FAQ - Résoudre vos problèmes avec le Ma-vin

FAQ - Résoudre vos problèmes avec le Ma-vin

mercredi 20 août 2008, par Julien H.

Cette partie de la FAQ [1] pour le robot Hitec Ma-vin concerne les petits problmes qu’on peut rencontrer lors de l’utilisation du robot.

Si vous ne trouvez pas l’information que vous cherchiez, contactez-nous : contact pobot.org

Concernant :
- l’installation
- le logiciel
- la connexion entre l’ordinateur et le robot
- le robot en lui-mme

Nous faisons appel aux distributeurs europens du robot pour obtenir des rponses chacun des problmes, donc n’hsitez pas nous faire part de vos soucis et d’enrichir cette base de connaissances qui sera utile tous.

Pour l’Europe, c’est la socit allemande Multiplex Modellsport GmbH & Co. KG qui reprsente Hitec Robotics. Leur site Internet (qu’on appellera "Robonova" pour simplifier) contient les diffrentes versions du logiciel et un systme de support / service aprs-vente : www.hitecrobotics.de ou www.robonova.de

 L’installation

Il existe plusieurs versions du logiciel en tlchargement sur le site Robonova :

- Ma-vin 1.0
- Ma-vin software 1.1
- Ma-vin software 1.11
- Ma-vin software 2.0 beta
- Ma-vin software 2.0 beta2

La prcaution d’usage concernant la ’beta’ :


This is beta Version of mavin software. Please use this with your own risk.

Je conseille quand mme de prendre la version 2.0, car la premire n’est vraiment pas pratique. Malheureusement il y a des petites contraintes pour ceux qui sont sous Windows Vista. Mais il y a une solution ! (si a ne marche pas, dites le nous !)

Si c’est votre cas (2.0 beta + Vista), pensez bien appliquer la modification du programme tel que c’est expliqu :


This software works under Windows Vista, but it needs a small change on setting. Under the Mavin.exe
Properties with right mouse click, please check the the privilege level - run this program as an administrator -,
so that it can function properly.

En traduction :


Ce logiciel fonctionne sous Windows Vista, mais ncessite un petit changement de paramtre. Dans les proprits du fichier Mavin.exe, obtenues en faisant un clic droit sur l’icne de ce fichier dans le rpertoire de votre disque (une fois install), vrifiez le niveau de privilge, en choisissant l’option telle que ce programme est excut en tant qu’administrateur.

A noter que la version Mavin Software 2.0 beta 2 sortie en juillet 2008 amliore le traitement de Windows Vista (tlchargement sur le site cit plus haut).

Problme n I1

Le problme est que je suis sous window vista et que je ne peux pas tlcharger le pilote. J’ai le message suivant : incompatible avec cet os, tlchargement interrompu

Tlchargez la version 2.0 beta 2 car la prise en charge de Windows Vista y est mieux gre. Nous n’avons pas connu de problme malgr plus de 35 installations diffrentes (y compris avec Windows sur hardware Apple Mac !)

Problme n I2

Je voulais savoir si c’est normal lorsque je clique sur help about mavin a n’affiche rien. comment savons nous la version que l’on utilise.

Effectivement, sur la version 2.0, la slection du menu Help / About Ma-vin n’affiche pas de fentre d’information. Il n’est donc pas possible de connatre la version du logiciel (sauf demander la personne qui a install le logiciel.

Mais les interfaces du logiciel sont bien diffrentes entre la V1 et la V2. Voici la version installe partir du CD-rom livr avec les robots Ma-vin (achetes en mai 2008), c’est une 1.0 et le menu fonctionne.

PNG - 174.5 ko
Fenêtre principale de l’IHM 1.0
PNG - 8.2 ko
PNG - 8 ko

Voici la version 2.0 beta tlcharge sur le site Robonova.

PNG - 90 ko
Fenêtre principale de l’IHM 2.0
PNG - 7.2 ko

Problme n I3

 Le logiciel

Les diffrentes versions (1.x et 2.x) du logiciel sont diffrentes. Il est donc possible que vous soyez surpris, notamment pour la logique des briques qui a chang.

Problme n L1

- version : Ma-vin 2.0


Dans les proprits des modules IR et photo, il manque les affirmations conditions pour que le programme fonctionne

Tout d’abord, il n’y a pas de module nomm "IR" mais un module PHOTO. Je confirme que ce sont bien les connexions normales (pas de bug du logiciel) et qu’elles fonctionnent trs bien. Par contre il faut comprendre leur logique, c’est ce que nous allons faire pas plus tard que maintenant :

Comment se servir du bloc "PHOTO" :

  1. choisissez si vous voulez utiliser les 3 capteurs de devant (FORWARD) ou les 3 capteurs de dessous (DOWNWARD) dans le menu droulant intitul "Sensor Direction".
  2. remplissez ensuite les 3 check-box en indiquant les capteurs que vous souhaitez utiliser : il n’y a pas de choix "l’un ou l’autre", la rponse boolenne qui sera donne par la brique ainsi paramtre sera l’exacte application de la slection que vous aurez faite. C’est—dire que tous les capteurs que vous avez slectionn ou non devront tre en tat visible ou non.

Attention, lorsqu’on utilise les capteurs en suiveur de ligne (DOWNWARD), on se trompe toujours les premires fois sur la signification d’une croix dans la check-box : est-ce que a signifie que le capteur voit du noir ou l’inverse est-ce que a signifie que le capteur voit du blanc ?? Et bien je ne rpondrai pas cette question : il est prfrable que vous testiez par vous-mme son fonctionnement pour mieux s’en souvenir et trouver le moyen mnmotechnique qui vous convient :)

Problme n L2


quand je veux tlcharger un programme avec mon robot j’ai le message suivant : "failed to open a port make sure the downald is conected". Pourtant le cble usb est bien connect

Passons sur la prcision du message d’erreur. La solution a t trouve toute seule : il faut allumer le robot pour que le programme puisse tre tlcharg. C’est—dire que mme si la connexion USB est active dans le logiciel [ici mettre photo], le tlchargement ne peut commencer que par la mise sous tension du robot.

Pour cette raison, il est prfrable d’avoir un petit support pour poser le robot au moment de tlcharger un nouveau programme, ou de faire prcder tous vos programmes par une petite temporisation car sinon le Ma-vin va vous filer entre les doigts avant que vous ayez pu dire "tlcharge-toi".

Problme n L3


message suivant : "compile failed"

La premire solution est de sauvegarder son programme, de redmarrer le logiciel et de ressayer. Si vous rencontrez toujours le problme, un de nos visiteurs (merci !) a rsolu le problme en changeant le mode de
compatibilit dans les proprits du programme (comme prsent dans le paragraphe sur l’installation sous Windows Vista), en slectionnant "Windows XP sp2".

Problme n L4


Pour les moteurs on utilise toujours par dfaut. A quoi servent les chiffres de 1 5 qui sont dans les proprits ?

Vous voulez certainement parler du premier champ des proprits, appel "Position" dans la version actuelle.

Cela correspond la position du module sur l’un des cinq emplacements (proprit commune tous les capteurs d’entre ou actionneurs en sortie).

Pour un moteur, pas d’emplacement mais la proprit est reste dans le logiciel. C’est donc bien entendu la valeur "default" qu’il faut utiliser.

Problme n L5


Dans le module cds pour les proprits il y a 2 petites flches de sens contraire, quelle en est l’utilisation dans les programmes ?

Le module CDS [2] est un capteur de lumire (photo-rsistance) qui fournit une information d’clairement ("illuminance" en anglais).

La valeur est comprise entre 1 et 5 dans le logiciel graphique et deux options de test sont disponibles : = ou <>. Ce ne sont pas deux flches, c’est le signe infrieur < suivi du signe suprieur > qui signifie de manire conventionnelle "diffrent de".

Si vous utilisez ce mode, les deux sorties "True" et "False" du module CDS vont avoir pour sens : "True si l’clairement reu est diffrent de x" o x est la valeur numrique slectionne dans les proprits.

Proprits du module CDS

On peut slectionner la position du module, ainsi que le test d’clairement lumineux, qu’il soit gal ou diffrent d’une valeur numrique comprise entre 1 et 5.

 Le manuel

Il faut reconnaitre que le manuel est dtaill (et multi-lingue) mais il est vrai aussi que dcrire des programmes informatiques sur papier n’est pas toujours ais, donc il est normal que vous ayez des questions.

Problme n M1


Dans le manuel, il semble qu’il y ait des erreurs de connections des modules dans les programmes "viteur d’obstacle" (chapitre 6.2.1) et "suiveur de ligne" (chapitre 6.3.1)

Personnellement je n’en vois pas. Chacun des cas semble test, avec le cas dfaut correctement test. A suivre...

Problme nM2


J’ai eu beau chercher le module rcepteur infra-rouge qui est pr-install sur la platine comme c’est dit dans le livre, je n’ai pas trouv. J’ai trouv un petit module dans la boite qui s’appelle ’remocon IR’, je pense que
c’est cela ?

Oui effectivement, la version 1.1 du robot a introduit entre autres changements le dport du rcepteur de la tlcommande sur un module enfichable. Le manuel n’a pas t mis jour mais heureusement il est assez facile de le retrouver (’remocon’ signifie ’remote controller’ et est une abrviation courante).

 Le robot

Comme on l’a dit plus haut, il existe l’heure actuelle (08-2008) deux versions du robot : 1.0 et 1.1 La version 1.0 avait des connecteurs de modules plus fragiles, un interrupteur dlicat et donc la version 1.1 est un progrs. Mais de ce fait, des diffrences existent sur les photos et dans le manuel (voir la section affrente) qui n’ont pas t modifies.

Problme n R1


O se trouve la gauche et la droite : en regardant devant ou en regardant derrire

La position des roues se dduit du sens dans lequel avance le robot : lorsque le robot avance, sa partie gauche se trouve notre gauche en regardant de derrire.

Problme n R2


Mon robot avance en reculant

Mme si d’un point de vue de votre programme, vous avez bien dcrit le dplacement du robot en considrant la gauche du robot selon la convention dcrite au problme nR1, il n’est pas impossible que vous ayez invers les deux connecteurs des moteurs courant continu (DC).

Suivez la mthode suivante :
- crez un programme simple : START—MOTOR—LOOP—END
- configurez le bloc MOTOR selon les paramtres : Default, Forward, Both, 7
- configurez le bloc LOOP selon le paramtre : 0 (boucle infinie)
- testez : si le robot se dplace en avant, c’est bon !
- sinon, teignez le robot
- inversez les connecteurs
- retestez : c’est bon cette fois ci !

Problme n R3


Les piles s’usent trop vite, a me cote cher !

Il existe deux alternatives :

  • utiliser des accus rechargeables (technologie Ni-MH ou Ni-Cd de taille AAA)
  • utiliser une alimentation externe 5V connectable sur la prise arrire ct du bouton d’arrt

Problme n R4


Si le robot Ma-vin tourne trop longtemps sur la mme roue, celle-ci se dbote. Je ne pense pas qu’il y ait de position particulire pour mettre la roue.

Effectivement, le robot est conu pour tre dmontable facilement et rapidement. De ce fait, la roue s’enfonce sur un axe mais n’est pas maintenue.

Lorsque le robot fait des courbes serres vitesse leve, la torsion exerce sur la roue fait qu’elle sort. Il faut donc fixer dfinitivement la roue avec de la colle forte si vous souhaitez utiliser ce type de
dplacement.

 En conclusion : cette rubrique vit grce vous !

Nous esprons que vous aurez trouv une rponse votre problme. Mais si ce n’est pas le cas, ne dsesprez pas :) Laissez nous un message et nous documenterons votre cas, en vous demandant de raliser les tests pour tre certains que vous arrivez comprendre nos explications.

C’est pratique et a rend service au plus grand nombre. contact pobot.org

mais aussi

Notre association serait trs heureuse de pouvoir investir dans plus de robots pour organiser des courses et faire dcouvrir la robotique au public le plus large : vous tes donc chaleureusement remerci d’avance pour tout don notre association.

Si vous souhaitez nous rejoindre et vivre encore plus intensment les nouvelles technologies, contactez-nous ! (lien dans le menu de gauche).


[1Foire Aux Questions

[2Cadmium Sulfide, le compos chimique semi-conducteur qui le compose

Vos commentaires

  • Le 20 octobre 2009 à 11:15, par ? En réponse à : FAQ - Compile Failed

    Bonjour, sur ma configuration, la compilation ne s’exécute pas correctement avec le logiciel Ma-Vin : (

    Le message retourné est : Compile Failed.

    Je précise que la compilation fonctionne avec l’environnement C (PN).

    Aussi j’aimerais pouvoir suivre le processus ! Savez vous s’il existe un fichier Log qui trace les erreurs ?

    Merci.

    Répondre à ce message

  • Le 11 octobre 2008 à 14:44, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

    Savez vous s’il y a d’autres sites que Hitec pour savoir quand les nouveautés pour ma-vin vont sortir , capteurs , buldozers etc ....

    • Le 12 octobre 2008 à 11:10, par Julien H. En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Non, pas d’autres sites que Robonova.de (le site d’Hitec consacré aux robots) et pour info la pince est prévue pour le second semestre 2008 donc on est en plein dedans, quelques problèmes de délai sans doute.

    • Le 3 décembre 2008 à 17:30, par mic En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Bonjour , j’ai demandé à Lextronic s’ils avaient des nouvelles pour les accessoires de Ma-Vin ils m’ont dit que le fournisseur avait annoncé pour 2009 les nouveautés sans préciser de date . Un petit bonjour à Julien qui m’a beaucoup aidé quand j’ai debuté avec ma-vin et que je remercie encore

    Répondre à ce message

  • Le 12 octobre 2008 à 15:23, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

    Bonjour , savez vous à quoi sert la led rouge qui est à droite à côté du bouton orange de ma-vin , car même avec des piles faibles je ne l’ai jamais vu s’allumer

    • Le 26 octobre 2008 à 17:46, par laulau En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Il y a une led D1 qui indique le transfert du programme et qui s’allume lors d’étapes dans le programme.
      L’autre led D3 s’allume lorsque le robot est sous tension.

    • Le 27 octobre 2008 à 15:43, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Bonjour , je pense que nous ne parlons pas de la même led car la led rouge doit normalemement s’allumer quand la tension des piles est en dessous de 5 volts , chose que je n’ai pas encore constaté ?

    • Le 27 octobre 2008 à 17:51, par Julien H. En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      N’hésitez pas à prendre des photos et à me les envoyer, je les intégrerai aux articles. Je me remets sur les articles Ma-vin d’ici la fin de semaine (avec un jeu spécial avec la télécommande notamment).

    • Le 1er novembre 2008 à 12:14, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Bonjour , on attends avec impatience le jeu avec la télécommande pour ma-vin , un passionné

    Répondre à ce message

  • Le 29 octobre 2008 à 14:14, par Laulau En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

    Ils indiquent que l’on peut utiliser un transfo de 5V mais si on calcule les piles ca fait 1.5V x 4 = 6V . Qu’elle est la tension maxi accepté dans le mavin ? il faut un transfo de 3V,4.5V ? mais de combien de mA 200mA, 500mA 1A, etc...?

    Est ce que l’on peut utiliser le transfo avec les piles dans le MAVIN ? ou il y a risque de surcharge piles + transfo soit 6V+ 5V= 12V ?

    • Le 29 octobre 2008 à 16:18, par Julien H. En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Les composants électroniques modernes (ici microcontrôleurs Atmel) supportent différentes tensions. A des tensions trop basses, ils fonctionnent mal et on peut endommager leur fonctionnement, tandis qu’à des tensions trop élevées on risque de les griller.

      La tension d’une pile n’est pas constante, elle descend rapidement. Sur des accus (piles rechargeables), il n’y a jamais 1,5V (on considère leur tension nominale à 1,2V) donc les 6V sont tolérés mais le fonctionnement idéal du Ma-vin est bien à 5V.

      Je pense qu’une alimentation de transfo de 4,5V fonctionnera. Pas au-dessus de 6V en tout cas, car il faut également compter qu’une alimentation classique (c’est à dire un transfo réglable standard non stabilisé) fournit toujours au-dessus de la tension indiquée.

      Concernant l’intensité, 200 mA seront suffisants : il faut bien voir que le transfo sert à économiser les piles lors des tests. Donc même si les moteurs ne sont pas au meilleur de leur capacité, le robot fonctionnera. Bien sûr qui peut le plus peut le moins donc 500mA et 1A fonctionnent aussi.

      5V à 200mA... ça ressemble bien à de l’alimentation USB —> il doit être possible d’utiliser un câble USB pour alimenter le Ma-vin.

      A mon avis il est logique de garder les piles dans le Ma-vin même si on utilise une alimentation externe.

      Tout cela est à vérifier mais ça semble ok.

    • Le 29 octobre 2008 à 16:29, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      En utilisant une alimentation externe le circuit pile est déconnecté , donc comme dit Julien aucun danger pour le ma-vin

    Répondre à ce message

  • Le 11 octobre 2008 à 15:08, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

    Bonjour pour inciter les programmeurs amateurs de ma-vin , de publier sur le site les meilleurs programmes il serait peut être intéressant de faire un challenge avec une petite récompense pour les meilleurs

    • Le 12 octobre 2008 à 11:53, par Julien H. En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Oui, tout à fait d’accord, nous organisons déjà ce type de concours. Je mettrai en ligne les règlements des deux épreuves.

      Vous pourrez participer en envoyant vos programmes. Par contre, aucune récompense, nous n’avons aucun budget pour cela et nous mettons devant tout autre intérêt le partage de connaissances technologiques.

    • Le 12 octobre 2008 à 13:17, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Bonjour , serait il possible d’avoir un endroit pour poster les sujets qui nous intéressent sur les autres robots ?

    • Le 13 octobre 2008 à 11:58, par Julien H. En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Vous pouvez vous inscrire sur le site Pobot (bouton "Inscription" dans le menu de gauche) et vous deviendrez ainsi rédacteur d’articles, et vous pourrez poster vos propres réalisations et décrire les sujets qui vous intéressent.

    Répondre à ce message

  • Le 11 octobre 2008 à 14:38, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

    Bonjour , si vous avez des idées pour fabriquer d’autre capteurs pour ma-vin ce serait intéressant

    Répondre à ce message

  • Le 5 octobre 2008 à 14:47, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

    Je ne sais pas si vous avez le même probléme , mais le simulateur de programme ne fonctionne pas bien dans les programmes pour Ma-Vin

    • Le 7 octobre 2008 à 09:58, par Julien H. En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Pouvez-vous préciser "ne fonctionne pas bien" ? Car pour ma part je l’utilise et je n’ai pas constaté de problèmes. Si vous pouviez m’envoyer le programme qui provoque ce disfonctionnement, je regarderai.

    • Le 11 octobre 2008 à 08:47, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Bonjour , au début de la simulation le module est entouré et clignote , mais au lieu d’aller jusqu’a la fin du programme au bout de 3 ou 4 modules il reste bloqué sur le même

    • Le 11 octobre 2008 à 09:29, par Julien H. En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Oui, il doit s’agir d’un module de capteur, le simulateur attends que vous choisissiez le chemin en cliquant sur T ou F selon le cas que vous souhaitez simuler.

    • Le 11 octobre 2008 à 10:48, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Oui effectivement , j’ai essayé pour le simulateur c’est bien ça il attend que l’on lui indique vrai ou faux pour qu’il continue .

    Répondre à ce message

  • Le 5 octobre 2008 à 14:56, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

    Bonjour quels programmes avez vous déja testé en compétion avec Ma’Vin ? Un peux plus de vidéos seraient les bien venues

    • Le 7 octobre 2008 à 10:08, par Julien H. En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Des programmes faits par les concurrents, sur deux circuits : suivi de ligne et sumo (évitement d’adversaire et stratégie).

      Quels types de vidéos : pour résoudre les problèmes avec le Ma-vin (on est sur la page de la FAQ) ou des exemples du robot en fonctionnement ?

      Pour le dernier cas, je les mettrai sur l’article du Ma-vin. Il y a déjà une vidéo de Plein Sud TV normalement.

    • Le 11 octobre 2008 à 08:33, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Bonjour , comment faut il procéder pour envoyer une vidéo ou des photos sur le forum . Faut il compresser ?

    • Le 11 octobre 2008 à 09:24, par Julien H. En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

      Le forum est limité à des échanges par textes. Vous pouvez soit m’envoyer vos vidéos/photos par mail (julien pobot.org) ou vous inscrire en tant que rédacteur pour écrire vos propres articles (soumis à validation des administrateurs). Voir liens "Inscription" et "Contact" dans le menu de gauche.

    Répondre à ce message

  • Le 5 octobre 2008 à 14:38, par ? En réponse à : FAQ - Résoudre vos problèmes avec le Ma-vin

    Bonjour pour savoir si une télécommande fonctionne , il suffit d’orienter un appareil photo ou un camescope en position recording et vous verrez dans le viseur s’éclairer les leds IR

    Répondre à ce message

Un message, un commentaire ?

modération a priori

Attention, votre message n’apparaîtra qu’après avoir été relu et approuvé.

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici
  • Ce formulaire accepte les raccourcis SPIP [->url] {{gras}} {italique} <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document