Club robotique de Sophia-Antipolis

Accueil > ... > Forum 934

Péter correctement les plombs

4 avril 2010, 00:30

Je veux protéger le code de mon ATmega328 sur mon Arduino Duemilanove.

J’ai utilisé PonyProg2000 Version 2.07c, mais je suis incapable de faire quoi que ce soit.

Voici ce que j’ai fait

1) j’ai brancher mon Arduino à l’ordinateur avec le cable USB.

2) Dans PonyProg je suis allé dans le menu Setup->Interface Setup... et j’ai sélectionné Serial et SI Prog API et j’ai choisi le bon port COM.

3) Ensuite j’ai sélectionné dans le menu Device->AVR micro->ATmega32.

4) Après j’ai choisi l’option Command->Security and Configuration Bits... pour modifier les valeurs des fusibles de protection.

5) ensuite il y a une fenêtre qui est affiché et dans la fenêtre c’est écrit Reading Security Bits et le pourcentage reste à 0% pendant environ 5 minutes et après il y a une autre fenêtre qui est afficher et c’est écrit ce message d’erreur "Device missing or unknown device -24".

Je doit faire quoi pour modifier les valeurs des fusibles de protection avec PonyProg ?

Dois-je absolument utiliser la méthode avec le port parallèle pour que ça fonctionne ?

Dans PonyProg il y a pas d’option ATmega328 dans Device->AVR micro.
Alors J’ai mit l’option ATmega32.

Merci

Un message, un commentaire ?

modération a priori

Attention, votre message n’apparaîtra qu’après avoir été relu et approuvé.

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici
  • Ce formulaire accepte les raccourcis SPIP [->url] {{gras}} {italique} <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.