Club robotique de Sophia-Antipolis

Accueil > Projets et études > Nos robots > Robots Eurobot > Robot Eurobot 2011 > Monte-charge du robot 2011

Monte-charge du robot 2011

lundi 3 octobre 2011, par Stephan

Le monte-charge est un actionneur spécifique du robot PoBot 2011 répondant à un besoin du règlement Eurobot : empiler des pions les uns sur les autres. Mais il faisait bien plus que ça comme vous allez pouvoir le constater.

JPEG - 483.2 ko

Il est composé d’un châssis en échelle sur lequel coulisse une plaque de fixation verticale mise en mouvement linéaire par une vis sans fin.

Massif, il s’intégrait parfaitement dans le châssis :

JPEG - 434.1 ko

 La vis trapézoïdale

Contrairement à une poulie, la vis à pas trapézoïdal apporte de la précision et de la force en même temps : elle permet au monte-charge de rester en position sans consommer de courant. Elle permet également d’avoir une plus grande résistance mécanique.

Elle a été usinée sur mesure (diamètre 12mm, pas de 3), cependant ce type de produit existe tout fait dans la même dimension.

Moteur pas à pas, alimenté en 40V, couple de 9 kg.cm

Pour la maintenir, en général on utilise des roulements, et il faut donc usiner les extrémités au tour (de même que pour l’accouplement moteur ou la poulie).

JPEG - 289.9 ko

Concernant les deux axes, j’avais mis de l’axe rectifié de 12mm avec glissières à billes.

Concernant les deux plaques en aluminium (haut et bas) où viennent se placer les axes et les roulements, je les ai faites sur mesure avec ma machine CNC. Elles sont en alu AU4G de 10 mm d’épaisseur.

 Transmission par courroie

Comme vous le constatez sur la photo, il y a une courroie pour faire tourner la vis sans fin. De plus les poulies sont de même taille, il n’y a donc pas de démultiplication, un des avantages (le seul ?) de cette solution.

JPEG - 393.9 ko

Il y a débat concernant l’utilisation d’une courroie plutôt qu’une prise directe ou des engrenages. Ici c’est un problème de place qui a rendu nécessaire la courroie.

 Moteur

Le moteur est fixé en haut de la vis, ce qui permettait de faire descendre le monte-charge le plus bas possible. De toute façon, l’encombrement était trop important à cause des moteurs de propulsion.

JPEG - 358.3 ko

Le moteur pas-à-pas utilisé faisait donc monter le centre de gravité, mais cela ne posait pas de problème en raison du poids... conséquent... du robot.

JPEG - 434.1 ko

 Version terminée

Pour illustrer les réponses ci-dessous, voici une photo du monte-charge terminé avec son électronique :

JPEG - 412.3 ko
Face avant

Vos commentaires

  • Le 5 octobre 2011 à 00:21, par Stephan En réponse à : Monte-charge du robot 2011

    Bonjour,

    effectivement, sur les photos on ne voit que la partie mécanique, mais il y a également une carte électronique qui vient se placer au fond, derrière les glissières et la vis trapézoidale, et qui a pour but de gérer le pas à pas du monte charge ainsi que les pinces (pas sur la photo), de fournir les 8 ampères nécessaires aux servos des pinces, plus quelques autres bricoles.

    N’est pas présent non plus sur la photo un switch positionné sur le plateau supérieur et chargé de fournir une info sur le point haut du monte charge. A la mise sous tension on initialise en faisant monter la mécanique jusqu’au point haut, à partir de là on gère en faisant du comptage de pas.

    Le pas à pas consommait un peu plus de 2 A

    Stephan

    Répondre à ce message

  • Le 4 octobre 2011 à 22:20, par Alban En réponse à : Monte-charge du robot 2011

    GENIAL !!!!

    Répondre à ce message

  • Le 3 octobre 2011 à 20:51, par Keuronde En réponse à : Monte-charge du robot 2011

    J’ai trois petites questions qui me sont venues en lisant l’article :

    Je ne vois pas de contacteurs pour connaître la position de l’ascenseur, ont-il été rajoutés après ou la position de l’ascenseur était-elle estimée grâce aux commandes du moteurs pas-à-pas ?

    Si c’est la deuxième solution, la position d’origine de l’ascenseur devait être connue, non ? Le positionniez vous à l’œil ou avec un système plus précis ?

    Enfin, par curiosité, quel courant consommait votre moteur ?

    • Le 4 octobre 2011 à 22:19, par Julien H. En réponse à : Monte-charge du robot 2011

      Il y a effectivement eu un contacteur en haut, mais je n’en ai pas souvenir en bas. Je vérifierai (le robot est en vacances chez moi...) mais il est probable qu’après une prise d’origine en haut, il ait été simple de tenir compte des rotations du moteur pas à pas.

      Pour la consommation, je laisse Stephan répondre.

    Répondre à ce message

Un message, un commentaire ?

modération a priori

Attention, votre message n’apparaîtra qu’après avoir été relu et approuvé.

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici
  • Ce formulaire accepte les raccourcis SPIP [->url] {{gras}} {italique} <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document